An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)
how to ectify the problem.

Niradhip ChakrabortyPosted Jul 11, 2008, 11:24 AM
Select sql server 2005 Go to configuration tool, select sql server surface area configuration.
Next select surface area configuration for srvices and connections.Then select remote connections.
Under remote connections select local and remote connections option and finally select using both TCP\Ip and named pipes
ArshadPosted Jul 11, 2008, 10:00 AM