Error problem while running website
Error 7 It is an error to use a section registered as allowDefinition='MachineToApplication' beyond application level. This error can be caused by a virtual directory not being configured as an application in IIS. D:\akhilesh\Kiosk Control System\Kiosk Control System\Web.Config 29

SenthilkumarPosted Apr 2, 2012, 2:21 AM
First question i would like ask to you is dd you move your web.config from root to sub directories?
If yes then you can have the web.config in the sub directory. But in the root level it should have the default web.config file.
Anyway you try this.
Give your virtual directory an Application Name that does not have dots (.) in the name. To make sure you are not having naming issues, give a short name such as MK as your Virtual Directory name.