
IBM reported multiple vulnerabilities in Langflow OSS, including flaws that could allow authentication controls to be bypassed and arbitrary code to be executed remotely without authentication. The affected range is Langflow OSS 1.0.0 through 1.12.8. IBM also identified risks involving API credential exposure, information disclosure, and vulnerabilities in included dependencies. IBM recommends upgrading affected installations to Langflow OSS 1.13.0 and reviewing the release-specific upgrade instructions.
Why it matters
Organizations running Langflow should treat the issue as a server-side security risk, particularly where the service or MCP-related functionality is network accessible. Administrators should inventory deployments, back up relevant data and configuration, and upgrade affected installations to 1.13.0 rather than relying only on authentication settings.
Key points
- Multiple vulnerabilities affect Langflow OSS, including critical authentication-bypass and remote-code-execution issues.
- Some of the vulnerabilities can be exploited by unauthenticated remote attackers, while others involve authenticated or low-privilege access.
- Langflow OSS versions 1.0.0 through 1.12.8 are listed as affected.
- IBM recommends upgrading to Langflow OSS 1.13.0; it lists no separate workaround.
- Langflow is an open-source visual tool for constructing and executing AI-powered agent workflows.
Based on reporting by The original announcement and The Hacker News.






Join the conversation! Your thoughts help the community grow.